Back to overview
Degraded

Increased Site Latency

Aug 21 at 03:03pm EDT
Affected services
udio.com

Resolved
Aug 21 at 03:48pm EDT

The upstream issue has been resolved.

Created
Aug 21 at 03:03pm EDT

The site is experiencing increased latency and timeouts for requests due to an incident with an upstream provider. The provider has informed us that the issue has been isolated and a fix is being worked on.